# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{1,2}:[0-9]{2}) (AM|PM)(\n)(.*)\n"
test_str = ("5:47 PM\n"
"[EASY] Panzer Pebble joined the server\n"
"5:47 PM\n"
"Trigger executed raw command message \"76561199679367168\" Welcome to EASY Company | Level 50+! If you have any issues, please report it by typing !admin (reason) in chat. Come check us out at discord.gg/easycompany. You MUST be level 50 or higher to play on this server and level 75 or higher to play commander.\n"
"5:47 PM\n"
"Player [EASY] Panzer Pebble switched from None to Allies\n"
"5:47 PM\n"
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [We are trying to populate the server which means special rules apply.\n"
"5:56 PM\n"
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:\n"
"5:59 PM\n"
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [We are trying to populate the server which means special rules apply.\n"
"5:59 PM\n"
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [This server is under level thresholds control.\n"
"6:18 PM\n"
"Player [EASY] Panzer Pebble switched from None to Axis\n"
"7:28 PM\n"
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:\n"
"7:48 PM\n"
"MASTER CHIEF (Axis) killed [EASY] Panzer Pebble (Allies) with GEWEHR 43\n"
"7:49 PM\n"
"Yustitsiya (Axis) killed [EASY] Panzer Pebble (Allies) with MP40\n"
"9:00 PM\n"
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:")
subst = "\\g<1>\\g<2> \\g<4>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.