import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,2}:[0-9]{2}) (AM|PM)(\\n)(.*)\\n";
final String string = "5:47 PM\n"
+ "[EASY] Panzer Pebble joined the server\n"
+ "5:47 PM\n"
+ "Trigger executed raw command message \"76561199679367168\" Welcome to EASY Company | Level 50+! If you have any issues, please report it by typing !admin (reason) in chat. Come check us out at discord.gg/easycompany. You MUST be level 50 or higher to play on this server and level 75 or higher to play commander.\n"
+ "5:47 PM\n"
+ "Player [EASY] Panzer Pebble switched from None to Allies\n"
+ "5:47 PM\n"
+ "MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [We are trying to populate the server which means special rules apply.\n"
+ "5:56 PM\n"
+ "MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:\n"
+ "5:59 PM\n"
+ "MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [We are trying to populate the server which means special rules apply.\n"
+ "5:59 PM\n"
+ "MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [This server is under level thresholds control.\n"
+ "6:18 PM\n"
+ "Player [EASY] Panzer Pebble switched from None to Axis\n"
+ "7:28 PM\n"
+ "MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:\n"
+ "7:48 PM\n"
+ "MASTER CHIEF (Axis) killed [EASY] Panzer Pebble (Allies) with GEWEHR 43\n"
+ "7:49 PM\n"
+ "Yustitsiya (Axis) killed [EASY] Panzer Pebble (Allies) with MP40\n"
+ "9:00 PM\n"
+ "MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:";
final String subst = "\\g<1>\\g<2> \\g<4>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}