#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)([0-9]{1,2}:[0-9]{2}) (AM|PM)(\n)(.*)\n"
Local $sString = "5:47 PM" & @CRLF & _
"[EASY] Panzer Pebble joined the server" & @CRLF & _
"5:47 PM" & @CRLF & _
"Trigger executed raw command message "76561199679367168" Welcome to EASY Company | Level 50+! If you have any issues, please report it by typing !admin (reason) in chat. Come check us out at discord.gg/easycompany. You MUST be level 50 or higher to play on this server and level 75 or higher to play commander." & @CRLF & _
"5:47 PM" & @CRLF & _
"Player [EASY] Panzer Pebble switched from None to Allies" & @CRLF & _
"5:47 PM" & @CRLF & _
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [We are trying to populate the server which means special rules apply." & @CRLF & _
"5:56 PM" & @CRLF & _
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:" & @CRLF & _
"5:59 PM" & @CRLF & _
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [We are trying to populate the server which means special rules apply." & @CRLF & _
"5:59 PM" & @CRLF & _
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [This server is under level thresholds control." & @CRLF & _
"6:18 PM" & @CRLF & _
"Player [EASY] Panzer Pebble switched from None to Axis" & @CRLF & _
"7:28 PM" & @CRLF & _
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:" & @CRLF & _
"7:48 PM" & @CRLF & _
"MASTER CHIEF (Axis) killed [EASY] Panzer Pebble (Allies) with GEWEHR 43" & @CRLF & _
"7:49 PM" & @CRLF & _
"Yustitsiya (Axis) killed [EASY] Panzer Pebble (Allies) with MP40" & @CRLF & _
"9:00 PM" & @CRLF & _
"MESSAGE: player [[EASY] Panzer Pebble(76561199679367168)], content [Vote for the nextmap:"
Local $sSubst = "\g<1>\g<2> \g<4>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)