$re = '/<it-grid[\n\s\S]*?([\[\(]selectedItems[\]\)])/m';
$str = ' <it-grid
[columns]="groupExternalColumns"
[items]="groupExternalItems"
[selection]="groupExternalGridSelection"
[selectedItems]="groupExternalFilterSelection"
(selectedItemsChange)="onSelectedExternalGroupsChanged($event)"
[cellTemplates]="{ nameAndDesc: nameTemplate, settings: settingsTemplate }"
[idPrefix]="\'groupExternalSelectorGrid\'"
[comparator]="gridPrincipalCompare"
>
<it-grid
class="activities-list activities-list__table"
[selection]="gridSelection"
[paginationOptions]="gridPaginationOptions"
(paginationChanged)="paginationChanged()"
[idPrefix]="\'endpointMonitoringListGrid\'"
[columns]="endpointMonitoringColumns"
[items$]="endpointMonitoringData$"
[highlightHovered]="true"
[selectedItemNotifier]="selectedConfiguration$"
[cellTemplates]="{
display: displayTemplate
}"
(selectionChange)="onGridSelectionChanged($event)"
(columnRemove)="onGridColumnRemoved($event)"
[useCustomContextMenu]="true"
(customContextMenuClick)="openContextMenu($event)"
(columnFilter)="filterOpen($event)"
>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);