import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<it-grid[\\n\\s\\S]*?([\\[\\(]selectedItems[\\]\\)])";
final String string = " <it-grid\n"
+ " [columns]=\"groupExternalColumns\"\n"
+ " [items]=\"groupExternalItems\"\n"
+ " [selection]=\"groupExternalGridSelection\"\n"
+ " [selectedItems]=\"groupExternalFilterSelection\"\n"
+ " (selectedItemsChange)=\"onSelectedExternalGroupsChanged($event)\"\n"
+ " [cellTemplates]=\"{ nameAndDesc: nameTemplate, settings: settingsTemplate }\"\n"
+ " [idPrefix]=\"'groupExternalSelectorGrid'\"\n"
+ " [comparator]=\"gridPrincipalCompare\"\n"
+ " >\n\n\n"
+ " <it-grid\n"
+ " class=\"activities-list activities-list__table\"\n"
+ " [selection]=\"gridSelection\"\n"
+ " [paginationOptions]=\"gridPaginationOptions\"\n"
+ " (paginationChanged)=\"paginationChanged()\"\n"
+ " [idPrefix]=\"'endpointMonitoringListGrid'\"\n"
+ " [columns]=\"endpointMonitoringColumns\"\n"
+ " [items$]=\"endpointMonitoringData$\"\n"
+ " [highlightHovered]=\"true\"\n"
+ " [selectedItemNotifier]=\"selectedConfiguration$\"\n"
+ " [cellTemplates]=\"{\n"
+ " display: displayTemplate\n"
+ " }\"\n"
+ " (selectionChange)=\"onGridSelectionChanged($event)\"\n"
+ " (columnRemove)=\"onGridColumnRemoved($event)\"\n"
+ " [useCustomContextMenu]=\"true\"\n"
+ " (customContextMenuClick)=\"openContextMenu($event)\"\n"
+ " (columnFilter)=\"filterOpen($event)\"\n"
+ " >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}