#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<it-grid[\n\s\S]*?([\[\(]selectedItems[\]\)])"
Local $sString = " <it-grid" & @CRLF & _
" [columns]="groupExternalColumns"" & @CRLF & _
" [items]="groupExternalItems"" & @CRLF & _
" [selection]="groupExternalGridSelection"" & @CRLF & _
" [selectedItems]="groupExternalFilterSelection"" & @CRLF & _
" (selectedItemsChange)="onSelectedExternalGroupsChanged($event)"" & @CRLF & _
" [cellTemplates]="{ nameAndDesc: nameTemplate, settings: settingsTemplate }"" & @CRLF & _
" [idPrefix]="'groupExternalSelectorGrid'"" & @CRLF & _
" [comparator]="gridPrincipalCompare"" & @CRLF & _
" >" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <it-grid" & @CRLF & _
" class="activities-list activities-list__table"" & @CRLF & _
" [selection]="gridSelection"" & @CRLF & _
" [paginationOptions]="gridPaginationOptions"" & @CRLF & _
" (paginationChanged)="paginationChanged()"" & @CRLF & _
" [idPrefix]="'endpointMonitoringListGrid'"" & @CRLF & _
" [columns]="endpointMonitoringColumns"" & @CRLF & _
" [items$]="endpointMonitoringData$"" & @CRLF & _
" [highlightHovered]="true"" & @CRLF & _
" [selectedItemNotifier]="selectedConfiguration$"" & @CRLF & _
" [cellTemplates]="{" & @CRLF & _
" display: displayTemplate" & @CRLF & _
" }"" & @CRLF & _
" (selectionChange)="onGridSelectionChanged($event)"" & @CRLF & _
" (columnRemove)="onGridColumnRemoved($event)"" & @CRLF & _
" [useCustomContextMenu]="true"" & @CRLF & _
" (customContextMenuClick)="openContextMenu($event)"" & @CRLF & _
" (columnFilter)="filterOpen($event)"" & @CRLF & _
" >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")