// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\D*(?<number>0*(?<nonzeros>\d+))(?<suffix>.*)$").unwrap();
let string = "GE000123-Example
F000123
SEE000000Test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}