$re = '/^\D*(?<number>0*(?<nonzeros>\d+))(?<suffix>.*)$/m';
$str = 'GE000123-Example
F000123
SEE000000Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);