package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D*(?<number>0*(?<nonzeros>\d+))(?<suffix>.*)$`)
var str = `GE000123-Example
F000123
SEE000000Test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}