const regex = /^(?:(?:\b([0-9]|[1-9][0-9])\b)(?:\.\b([0-9]|[1-9][0-9])\b)?|.\b([0-9]|[1-9][0-9])\b)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\b([0-9]|[1-9][0-9])\\b)(?:\\.\\b([0-9]|[1-9][0-9])\\b)?|.\\b([0-9]|[1-9][0-9])\\b)$', 'gm')
const str = `12
12.32
12
21.23
23.45
45.57
23.98
1.87
98.98`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}