import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\b([0-9]|[1-9][0-9])\\b)(?:\\.\\b([0-9]|[1-9][0-9])\\b)?|.\\b([0-9]|[1-9][0-9])\\b)$";
final String string = "12\n"
+ "12.32\n"
+ "12\n"
+ "21.23\n"
+ "23.45\n"
+ "45.57\n"
+ "23.98\n"
+ "1.87\n"
+ "98.98";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}