package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\b([0-9]|[1-9][0-9])\b)(?:\.\b([0-9]|[1-9][0-9])\b)?|.\b([0-9]|[1-9][0-9])\b)$`)
var str = `12
12.32
12
21.23
23.45
45.57
23.98
1.87
98.98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}