// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{0,9}(-[0-9]{0,4})?$").unwrap();
let string = "NoBcAl
A
-
9-
-9
-
9-
99-
999-
9999-
99999-
999999-
9999999-
99999999-
999999999
9999999999
9999999999-
9999999999-9
999999999-
999999999-9
999999999-99
999999999-999
999999999-9999
999999999--9999
999999999-99999
999999999-999999
999999999-999999-
-9
-99
-999
-9999
-99999
9-9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}