# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9]{0,9}(-[0-9]{0,4})?$"
test_str = ("NoBcAl\n"
"A\n"
"-\n"
"9-\n"
"-9\n"
"-\n"
"9-\n"
"99-\n"
"999-\n"
"9999-\n"
"99999-\n"
"999999-\n"
"9999999-\n"
"99999999-\n"
"999999999\n"
"9999999999\n"
"9999999999-\n"
"9999999999-9\n"
"999999999-\n"
"999999999-9\n"
"999999999-99\n"
"999999999-999\n"
"999999999-9999\n"
"999999999--9999\n"
"999999999-99999\n"
"999999999-999999\n"
"999999999-999999-\n"
"-9\n"
"-99\n"
"-999\n"
"-9999\n"
"-99999\n"
"9-9")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.