const regex = /^[0-9]{0,9}(-[0-9]{0,4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{0,9}(-[0-9]{0,4})?$', 'gm')
const str = `NoBcAl
A
-
9-
-9
-
9-
99-
999-
9999-
99999-
999999-
9999999-
99999999-
999999999
9999999999
9999999999-
9999999999-9
999999999-
999999999-9
999999999-99
999999999-999
999999999-9999
999999999--9999
999999999-99999
999999999-999999
999999999-999999-
-9
-99
-999
-9999
-99999
9-9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}