$re = '/([^\s]+:)?"([^"]*)"|([^\s]+:)?[^\s"]+/';
$str = 'hola mundo "hola mundo" k:hola k:"hola mundo" "k l":"hola mundo"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);