package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\s]+:)?"([^"]*)"|([^\s]+:)?[^\s"]+`)
var str = `hola mundo "hola mundo" k:hola k:"hola mundo" "k l":"hola mundo"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}