import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\s]+:)?\"([^\"]*)\"|([^\\s]+:)?[^\\s\"]+";
final String string = "hola mundo \"hola mundo\" k:hola k:\"hola mundo\" \"k l\":\"hola mundo\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}