$re = '/(?<=(|G|M|K|h|da|d|c|m|u|n))(?=(m|g|s|A|K|mol|cd)\b)/';
$str = 'G, M, k, h, da, d, c, m, u, n
m, g, s, A, K, mol, cd
132mmol
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);