#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=(|G|M|K|h|da|d|c|m|u|n))(?=(m|g|s|A|K|mol|cd)\b)"
Local $sString = "G, M, k, h, da, d, c, m, u, n" & @CRLF & _
"m, g, s, A, K, mol, cd" & @CRLF & _
"" & @CRLF & _
"132mmol" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")