using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(|G|M|K|h|da|d|c|m|u|n))(?=(m|g|s|A|K|mol|cd)\b)";
string input = @"G, M, k, h, da, d, c, m, u, n
m, g, s, A, K, mol, cd
132mmol
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}