re = /\/(?<controlador>\w*)(\/?)(?<accion>\w*)/
str = '/hola/pepe?variableGet=aslkdj'
# Print the match result
str.match(re) do |match|
puts match.to_s
end