const regex = /\/(?<controlador>\w*)(\/?)(?<accion>\w*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?<controlador>\\w*)(\\\/?)(?<accion>\\w*)', '')
const str = `/hola/pepe?variableGet=aslkdj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}