package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(?<controlador>\w*)(\/?)(?<accion>\w*)`)
var str = `/hola/pepe?variableGet=aslkdj`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}