$re = '/^[0[1-9]{2,3}-[0-9]{5,10}$/';
$str = '010-86551122';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);