package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0[1-9]{2,3}-[0-9]{5,10}$`)
var str = `010-86551122`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}