const regex = /^[0[1-9]{2,3}-[0-9]{5,10}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0[1-9]{2,3}-[0-9]{5,10}$', '')
const str = `010-86551122`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}