$re = '/^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$/m';
$str = '介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
#的简介
你知道#的知识吗';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);