package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$`)
var str = `介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
#的简介
你知道#的知识吗`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}