const regex = /^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$', 'gm')
const str = `介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
#的简介
你知道#的知识吗`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}