re = /(?'YMDyear'[\d]{4})?\/(?'YMDmonth'[\d]{2})\/(?'YMDday'[\d]{2})|(?'DMYday'[\d]{2})\/(?'DMYmonth'[\d]{2})\/(?'DMYyear'[\d]{4})/im
str = '01/14/2020
2020/01/31
01/01/2020
Test 01/01/1970
Bla bla 01/01/1970 hello!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end