import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'YMDyear'[\\d]{4})?\\/(?'YMDmonth'[\\d]{2})\\/(?'YMDday'[\\d]{2})|(?'DMYday'[\\d]{2})\\/(?'DMYmonth'[\\d]{2})\\/(?'DMYyear'[\\d]{4})";
final String string = "01/14/2020\n\n"
+ "2020/01/31\n\n"
+ "01/01/2020\n\n"
+ "Test 01/01/1970\n\n"
+ "Bla bla 01/01/1970 hello!";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}