$re = '/(?\'YMDyear\'[\d]{4})?\/(?\'YMDmonth\'[\d]{2})\/(?\'YMDday\'[\d]{2})|(?\'DMYday\'[\d]{2})\/(?\'DMYmonth\'[\d]{2})\/(?\'DMYyear\'[\d]{4})/sim';
$str = '01/14/2020
2020/01/31
01/01/2020
Test 01/01/1970
Bla bla 01/01/1970 hello!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);