$re = '/^https?://(www.)?[A-z0-9]+\.[A-z0-9]+$/m';
$str = 'emreyl.yldrm@yandex.com
emMMreylyl-yl@gmail.com
emMMreylyl-yl@gmail.com
-emreyl.yldrm@yandex.com
9emreyl.yldrm@yandex.com
https://regex101.com/r/IljuUr/
https://www.youtube.com
http://arin.com
https://stackoverflow.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);