using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?://(www.)?[A-z0-9]+\.[A-z0-9]+$";
string input = @"emreyl.yldrm@yandex.com
emMMreylyl-yl@gmail.com
emMMreylyl-yl@gmail.com
-emreyl.yldrm@yandex.com
9emreyl.yldrm@yandex.com
https://regex101.com/r/IljuUr/
https://www.youtube.com
http://arin.com
https://stackoverflow.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}