import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?://(www.)?[A-z0-9]+\\.[A-z0-9]+$";
final String string = "emreyl.yldrm@yandex.com\n"
+ "emMMreylyl-yl@gmail.com\n"
+ "emMMreylyl-yl@gmail.com\n"
+ "-emreyl.yldrm@yandex.com\n"
+ "9emreyl.yldrm@yandex.com\n\n"
+ "https://regex101.com/r/IljuUr/\n"
+ "https://www.youtube.com\n"
+ "http://arin.com\n"
+ "https://stackoverflow.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}