// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$").unwrap();
let string = "255.255.255.255
192.168.0.1
0.0.0.0
192.168.0.
192.168.0
192.1
0
33.33.33.33
2.2.99
255.255.255.255.
192.168.0.270
0.0.0.a
255.255.255. 255
192.168.0..
0.0.00.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}