const regex = /^(((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))\.?){0,3}((0)|([1-9]\d?)|(1\d\d)|(2[0-5]{2}))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((0)|([1-9]\\d?)|(1\\d\\d)|(2[0-5]{2}))\\.?){0,3}((0)|([1-9]\\d?)|(1\\d\\d)|(2[0-5]{2}))?$', 'gm')
const str = `255.255.255.255
192.168.0.1
0.0.0.0
192.168.0.
192.168.0
192.1
0
33.33.33.33
2.2.99
255.255.255.255.
192.168.0.270
0.0.0.a
255.255.255. 255
192.168.0..
0.0.00.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}