// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+)\s+([\w-]+)$\n").unwrap();
let string = "5067235721 24-FEB-16
5067245417 24-FEB-16
5067212004 10-FEB-16
5067148322 22-FEB-16
5067148330 19-FEB-16
5067148349 17-FEB-16
5067148357 17-FEB-16
5067148365 18-FEB-16
5067148373 17-FEB-16
5067148284 23-FEB-16
5067148292 23-FEB-16
5067148306 23-FEB-16
";
let substitution = " select \\1, to_date('\\2') from dual;\\nunion\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}