const regex = /^(\w+)\s+([\w-]+)$\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)\\s+([\\w-]+)$\\n', 'gm')
const str = `5067235721 24-FEB-16
5067245417 24-FEB-16
5067212004 10-FEB-16
5067148322 22-FEB-16
5067148330 19-FEB-16
5067148349 17-FEB-16
5067148357 17-FEB-16
5067148365 18-FEB-16
5067148373 17-FEB-16
5067148284 23-FEB-16
5067148292 23-FEB-16
5067148306 23-FEB-16
`;
const subst = ` select \1, to_date('\2') from dual;\nunion\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);