import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\s+([\\w-]+)$\\n";
final String string = "5067235721 24-FEB-16\n"
+ "5067245417 24-FEB-16\n"
+ "5067212004 10-FEB-16\n"
+ "5067148322 22-FEB-16\n"
+ "5067148330 19-FEB-16\n"
+ "5067148349 17-FEB-16\n"
+ "5067148357 17-FEB-16\n"
+ "5067148365 18-FEB-16\n"
+ "5067148373 17-FEB-16\n"
+ "5067148284 23-FEB-16\n"
+ "5067148292 23-FEB-16\n"
+ "5067148306 23-FEB-16\n";
final String subst = " select \\1, to_date('\\2') from dual;\\nunion\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}