$re = '/(\d+)(\d\d)|(\d+).(\d+)/m';
$str = '115
1x15
01x15
S01E05
S1E5
S1E05
S0105';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);