#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)(\d\d)|(\d+).(\d+)"
Local $sString = "115" & @CRLF & _
"1x15" & @CRLF & _
"01x15" & @CRLF & _
"S01E05" & @CRLF & _
"S1E5" & @CRLF & _
"S1E05" & @CRLF & _
"S0105"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")