import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(\\d\\d)|(\\d+).(\\d+)";
final String string = "115\n"
+ "1x15\n"
+ "01x15\n"
+ "S01E05\n"
+ "S1E5\n"
+ "S1E05\n"
+ "S0105";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}