$re = '/\[(?P<id>[\d.]+)\]/';
$str = '[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types "of symbols." ::==
And multiple lines describing futher information about this requirement.
With the possibility of being completely empty, placeholders should not match.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);