use strict;
my $str = '[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types "of symbols." ::==
And multiple lines describing futher information about this requirement.
With the possibility of being completely empty, placeholders should not match.';
my $regex = qr/\[(?P<id>[\d.]+)\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}