package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?P<id>[\d.]+)\]`)
var str = `[2.1.1.1] M_1.0_4.1.6.1: A requirement, may have any types "of symbols." ::==
And multiple lines describing futher information about this requirement.
With the possibility of being completely empty, placeholders should not match.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}