re = /\b(\w+)\b(\s\1)+/
str = 'Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result