use strict;
my $str = 'Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele.';
my $regex = qr/\b(\w+)\b(\s\1)+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";