const regex = /\b(\w+)\b(\s\1)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)\\b(\\s\\1)+', 'g')
const str = `Esse eh eh um texto texto texto de de um gago gago que que que que nao consegue consegue falar falar direito direito, entao estou estou corrigindo o texto texto texto texto texto pra ele ele.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);